Error with the recent earthquake generation

Array ( [id] => 20090330.1221 [type] => dyfi [lang] => en )

Error!

The ID number is not valid.