Error with the recent earthquake generation

Array ( [id] => 20111030.0839 [type] => dyfi [lang] => en )

Error!

The ID number is not valid.